加入收藏 | 设为首页 | 会员中心 | 我要投稿 淮安站长网 (https://www.0517zz.cn/)- 运营、云管理、经验、智能边缘、云硬盘!
当前位置: 首页 > 大数据 > 正文

lightoj1370——Bi-shoe and Phi-shoe(欧拉函数应用)

发布时间:2021-01-24 21:19:34 所属栏目:大数据 来源:网络整理
导读:Description Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students,so he asked his assistant Bi-Shoe to go to the market and buy the

Description
Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students,so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information,Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So,score of a bamboo of length 9 is 6 as 1,2,4,5,7,8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist,each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100),denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1,106].

Output
For each case,print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample Output
Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha

每个人有一个幸运值n,求欧拉函数Φ(x)>=n的最小的那个x。
根据欧拉函数的定义,素数n的欧拉函数值一定是n-1,所以在两个素数的区间(n1,n2)中的数(这肯定是合数)的欧拉函数值肯定小于Φ(n2)。所以给定一个数x,距这个数x+1的最近的素数就是要求的数,因为x+1以下的数的欧拉函数值肯定不会超过x。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <map>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1000005
#define mod 1000000007
using namespace std;
int p[MAXN];
void Init()
{
    for(int i=2; i<MAXN; ++i)
    {
        if(!p[i])
        {
            for(int j=i+i; j<=MAXN; j+=i)
                p[j]=1;
        }
    }
}
int main()
{
    Init();
    int t,cnt=1,n,m;
    scanf("%d",&t);
    while(t--)
    {
        long long ans=0;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%d",&m);
            for(int i=m+1;; ++i)
                if(p[i]==0)
                {
                    ans+=i;
                    break;
                }
        }
        printf("Case %d: %lld Xukhan",cnt++,ans);
    }
    return 0;
}

(编辑:淮安站长网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    推荐文章
      热点阅读